Porque o pessoal nao gosta da SOPA, mas do mercado dos ‘Congolenses’

Sinceramente, eu sou daqueles que pensa que já basta o tempo de impunidade em relação a distribuição de conteúdo de midia especializada. Ninguém, mas ninguém mesmo quer gastar milhões de dólares na produção dum filme e ver ele ser distribuído de forma anárquica a milhares de destinos sem ninguém pagar nada por isso. É injusto, é contra a força produtora do trabalho.

As produtoras de filmes adoptaram um esquema de roda-los pelos grandes cinemas e só depois de meses vender em formato DVD ou Blu-Ray. No caso da industria de musica o problema é mesmo alarmante. Em Angola foi adoptado o modelo de venda em praças e parques. É um modelo inteligente que permite uma certa ‘justiça’ para quem trabalhou duro na produção do seu trabalho musical. O problema é que ela já sabe que no dia seguinte a mesma vai estar disponível no mercado paralelo. Quem tiver duvida basta passar pelo mercado dos Congoleses (ou Congolenses, sei lá).
O que se passa ali é do piorio. A pirataria ali é lei e recomenda-se. Sei por experiência própria o que digo. Passei praticamente 4 anos diariamente por alí, porque era caminho da faculdade e do trabalho e já sabia que se o Matias Damásio lançou o disco no DOMINGO, na SEGUNDA de manha quando por ali passava, ja lá estava o CD, por pasmemo-nos… meros 100 kwanzas.
Alguém já pegou num papel e numa caneta para tentar saber quanto os artistas ganham e perdem (por dia, mês, ano) com a pirataria ali praticada? Ta ali um trabalho que poderia interessar a um graduando na área das economia e gestão (estou te dando uma ideia e você nem me vai dar nada).

Voltando ao assunto. Ali nos Congolenses, não propriamente dentro do mercado, mas ali fora próximo a estrada de Catete, podem ser encontrados discos de filmes, musicas, novelas, jogos para consolas etc, até entretenimento em formato K7 (não vá aparecer também em BETAMAX hehe).

No mercado dos Congoleses e nas redondezas, a venda de discos piratas rende mais que a venda de carne e peixe.

Mas isto já para não falar que agora até mesmo, canais de distribuição ONLINE garantem disponibilizar discos de cantores Angolanos horas depois de serem lançados nas praças e mercados de sei-la’o-que.

Tudo isto é perigoso e representa uma ameaça ao mercado, não duvidemos, essa é a verdade e ninguem a pode negar. É necessário fazer algo para parar por isso. O cantor Angolano Dog Murras acordou as 5h da manha, para impedir a venda de um de seus discos no mercado do Roque Santeiro. Foram encontradas a apreendidas centenas de copias do mesmo disco já prontinhas para serem distribuídas no ‘mercado negro’.

É verdade que essa é uma estratégia que não resulta quando se trata da Internet. Aqui é necessária uma outra estratégia. Não uma estratégia de dissuasão como a SOPA (Stop Online Privacy Act) , mas uma estratégia de aproximação, que combine com a aplicação de diversos padrões tecnológicos que permitissem a rápida aproximação do cliente final ao conteúdo musical. O Itunes e o Netflix são exemplos bem aplicados do que se espera disso.

As grandes produtoras mundiais sabem que de nada adianta lutarem contra a distribuição anárquica de conteúdo, seja no mercado paralelo de Luanda, ou no Cameló do Rio de Janeiro. É inútil, o que elas querem é controlar os seus conteúdos na Internet. Ali sim para elas se faz a diferença, porque estão envolvidos milhões de dólares em divisas.

O SOPA falha porque pretendeu ir longe de mais. Imagine ir preso e ainda possibilitar que uma autoridade derrube um site ou o feche só porque você fez um vídeo do seu bebé com uma musica de fundo do Sean Kingston e postou no Youtube? Isto sim é ir longe demais. Uma coisa ilegal seria sim postar um vídeo do próprio Sean Kingston sem autorização da produtora dele. A produtora tem todo direito de decidir o que pode ou não pode ser divulgado e quanto quer ou não quer ganhar pelo que produziu.

Eu defendo que exista alguma lei sim que regule a distribuição de conteúdo via Internet, mas que não seja como a SOPA, porque esta SOPA tem alguns ingredientes que sabem a pouco.

Anúncios

Agregaçao de links Ethernet usando Etherchannel (II)

Na primeira parte vimos alguns conceitos básicos sobre a tecnologia Etherchannel. Interessa pois, abordar apenas um aspecto e depois a parte prática.

Quando dois comutadores pretender formar um agregado de links eles precisam estar configurados com um dos dois protocolos a seguir: PAgP (Port Aggregation Protocol) ou LACP (Link Aggregation Protocol).
O PAgP é um protocolo proprietário pertencente a Cisco (Quem mais?) e o LACP (802.3ad) foi criado como um padrão aberto pela IEEE permitindo que comutadores de diferentes fabricantes possam formar agregados.

Cada um destes protocolos possui diferentes modos de operação. A seguinte tabela resume-os:

Mode Description
on Mode that forces the LAN port to channel unconditionally. In the on mode, a usable EtherChannel exists only when a LAN port group in the on mode is connected to another LAN port group in the on mode. Because ports configured in the on mode do not negotiate, there is no negotiation traffic between the ports. You cannot configure the on mode with an EtherChannel protocol. If one end uses the on mode, the other end must also.
auto PAgP mode that places a LAN port into a passive negotiating state, in which the port responds to PAgP packets it receives but does not initiate PAgP negotiation. (Default)
desirable PAgP mode that places a LAN port into an active negotiating state, in which the port initiates negotiations with other LAN ports by sending PAgP packets.
passive LACP mode that places a port into a passive negotiating state, in which the port responds to LACP packets it receives but does not initiate LACP negotiation. (Default)
active LACP mode that places a port into an active negotiating state, in which the port initiates negotiations with other ports by sending LACP packets.

O nosso exemplo é um cenário onde dois escritórios, IT e RH pertencem as VLANs 10 e 20 respectivamente. Para aumentar o débito binário no envio de dados entre os dois escritórios, o administrador de rede, decidiu usar a tecnologia Etherchannel entre eles. Na camada de distribuição está disponível um comutador Cisco 3560 Layer 3 que realizará encaminhamento InterVLAN entre os dois escritórios:

Etherchannel com roteador L3 e vlans

Foi providenciada redundância na camada física também, de modo que mesmo perdendo-se comunicação entre os comutadores IT, RH e o comutadorL3 existe uma ligação física redundante entre os comutadores IT e RH.

A seguinte tabela fornece um resumo do que se consegue com este cenário:

Ligação Débito Conseguido por Canal Interfaces utilizadas Protocolo Usado Port Canal de um Extremo a outro
ComutadorL3 -> IT (Vice-Versa) 400 Mbps Fa0/1-4 -> Fa0/1-4 PAgP 1 – 2
Comutador L3 -> RH (Vice-Versa) 400 Mbps Fa0/5-8 -> Fa0/5-8 PAgP 2 – 2
IT -> RH (Vice-Versa) 200 Mbps Fa0/23-24 -> Fa0/23-24 PAgP 1 – 1

Para conseguirmos configurar o nosso cenário, são necessários os seguintes seis passos:

1 – Criar as VLANs 10 (IT), 20 (RH) e 1 (Nativa) no comutador comutadorL3. Nos comutadores IT e RH configurar VLAN 1 (Nativa).

ComutadorL3

interface Vlan1
ip address 192.168.1.1 255.255.255.0

interface Vlan10
ip address 192.168.10.1 255.255.255.0

interface Vlan20
ip address 192.168.20.1 255.255.255.0

IT

interface Vlan1
ip address 192.168.1.10 255.255.255.0

RH

interface Vlan1
ip address 192.168.1.20 255.255.255.0

2 – Activar Comutadores IT e RH em modo VTP client. Criar domínio VTP SNNANGOLA nos 3 comutadores.

IT

IT#sh vtp st
VTP Version                     : 2
Configuration Revision          : 4
Maximum VLANs supported locally : 255
Number of existing VLANs        : 7
VTP Operating Mode              : Client
VTP Domain Name                 : SNNANGOLA

RH

RH#sh vtp st
VTP Version                     : 2
Configuration Revision          : 4
Maximum VLANs supported locally : 255
Number of existing VLANs        : 7
VTP Operating Mode              : Client
VTP Domain Name                 : SNNANGOLA

ComutadorL3

ComutadorL3#sh vtp st
VTP Version                     : 2
Configuration Revision          : 4
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 7
VTP Operating Mode              : Server
VTP Domain Name                 : SNNANGOLA

3 – Activar Gateway de saída nos comutadores IT e RH a apontar para endereço de VLAN nativa no comutadorL3.

IT

ip default-gateway 192.168.1.1

RH

ip default-gateway 192.168.1.1

4 – Criar Port-Channel entre os comutadores.

ComutadorL3

interface FastEthernet0/1
channel-group 1 mode desirable
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/2
channel-group 1 mode desirable
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/3
channel-group 1 mode desirable
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/4
channel-group 1 mode desirable
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/5
channel-group 2 mode desirable
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/6
channel-group 2 mode desirable
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/7
channel-group 2 mode desirable
switchport trunk encapsulation dot1q
switchport mode trunk

interface FastEthernet0/8
channel-group 2 mode desirable
switchport trunk encapsulation dot1q
switchport mode trunk

IT

interface FastEthernet0/1
channel-group 2 mode desirable
switchport mode trunk

interface FastEthernet0/2
channel-group 2 mode desirable
switchport mode trunk

interface FastEthernet0/3
channel-group 2 mode desirable
switchport mode trunk

interface FastEthernet0/4
channel-group 2 mode desirable
switchport mode trunk

interface FastEthernet0/23
channel-group 1 mode desirable
switchport mode trunk

interface FastEthernet0/24
channel-group 1 mode desirable
switchport mode trunk

RH

interface FastEthernet0/5
channel-group 2 mode desirable
switchport mode trunk

interface FastEthernet0/6
channel-group 2 mode desirable
switchport mode trunk

interface FastEthernet0/7
channel-group 2 mode desirable
switchport mode trunk

interface FastEthernet0/8
channel-group 2 mode desirable
switchport mode trunk

interface FastEthernet0/23
channel-group 1 mode desirable
switchport mode trunk

interface FastEthernet0/24
channel-group 1 mode desirable
switchport mode trunk

5 – Activar encaminhamento IP em comutadorL3

ip routing

6 – Activar Em IT e RH interfaces fa0/10 em access mode.

IT

interface FastEthernet0/10
switchport access vlan 10
switchport mode access

RH

interface FastEthernet0/10
switchport access vlan 20
switchport mode access

Os resultados nao enganam ninguém:

Ping PC1(IT) a PC2(RH) :

PC>ping 192.168.20.20

Pinging 192.168.20.20 with 32 bytes of data:

Request timed out.
Reply from 192.168.20.20: bytes=32 time=37ms TTL=127
Reply from 192.168.20.20: bytes=32 time=12ms TTL=127
Reply from 192.168.20.20: bytes=32 time=23ms TTL=127

Ping statistics for 192.168.20.20:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 12ms, Maximum = 37ms, Average = 24ms

Ping PC2(RH) a PC1(IT) :

PC>ping 192.168.10.10

Pinging 192.168.10.10 with 32 bytes of data:

Reply from 192.168.10.10: bytes=32 time=23ms TTL=127
Reply from 192.168.10.10: bytes=32 time=17ms TTL=127
Reply from 192.168.10.10: bytes=32 time=21ms TTL=127
Reply from 192.168.10.10: bytes=32 time=13ms TTL=127

Ping statistics for 192.168.10.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 13ms, Maximum = 23ms, Average = 18ms