Steve Jobs: Flash já não é necessario

Ja passou o tempo em que a Adobe tinha de se preocupar com a Microsoft. O problema chama-se agora Apple e Steve Jobs. O ‘pai grande’ do momento afirmou numa carta aberta que a tecnologia multimedia da Adobe já não é necessaria por causa dos enormes recursos que rouba dos processadores, do facto de ser uma tecnologia proprietaria e de não trabalhar bem com aplicações multitouch.

E a Adobe continua a assistir a este revanche sem nada poder fazer, num nicho que a Apple manda, faz e desfaz: Os dispositivos moveis, diga-se Ipad, Iphone etc.

fonte: http://br.noticias.yahoo.com/s/29042010/7/tecnologia-negocios-flash-ja-nao-necessario.html

Recuperando passwords em routers Cisco

Sempre é bom rever esses assuntos. As vezes surgem situações embaraçosas como estas e nem dá tempo para consultar na Google, logo é bom ter de cabeça.

Configura-se uma password de console terminal e outra do nivel enable:

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#enable pass
Router(config)#enable password ciscopass
Router(config)#line console 0
Router(config-line)#pass
Router(config-line)#password ciscopass
Router(config-line)#login
Router(config-line)#end

Supondo que sejam esquecidas. Como voltar a entrar no router?

O processo é quase similar. Reinicia-se o router (desligar e ligar cabo de força) e da-se um CTRL+BREAK (ou será apenas BREAK?) para entrar-se na ROMMON. Posto lá trocar o valor do confreg do default hexa 2102 para 2142 de modo que o bootstrap ignore quaisquer configurações existentes na NVRAM que indicam existencia de arquivo de configuração na NVRAM. Depois de modificado reinicar router com comando boot:

Self decompressing the image :
######
monitor: command “boot” aborted due to user interrupt
rommon 1 > confreg 0x2142
rommon 2 > boot
System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
Copyright (c) 2000 by cisco Systems, Inc.
cisco 2620 (MPC860) processor (revision 0x200) with 60416K/5120K bytes of memory

Self decompressing the image :
########################################################################## [OK]

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]:no

Depois de reiniciado configurar router com passwords de console e enable a nossa escolha (nao esquecer, heim?) mudar o valor do confreg para o seu valor default e copiar essa config (running) para a startup-config (se se fizesse o contrario seria um erro?) e reload. Usar as passwords definidas:

Router#conf t
Router(config)#line console 0
Router(config-line)#password passcisco
Router(config-line)#login
Router(config-line)#exit
Router(config)#enable password passcisco
Router(config)#exit
Router#

Verifique a config-reg. O valor é 2142 e necessita de ser alterado para 2102:

Router#sh ver
Router#sh version
Cisco Internetwork Operating System Software

63488K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2142

Alteramos então:

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#config-register 0x2102
Router(config)#exit

Router#copy running-config st
Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration…
[OK]
Router#reload
Proceed with reload? [confirm]

VTP: Vlan Trunking Protocol I

O protocolo VTP é um protocolo de layer 2 que serve para manter as informações de VLans consistentes num grupo de comutadores sobre um determinado dominio. Isto é de muita utilidade já que configurar as vlans manualmente pode acarretar nao apenas muitos erros, como pode ser muito trabalhoso em infras muito grandes. Com o VTP é possivel definir um ou um conjunto de comutadores que transmitirão as informações sobre as vlans por meio de trunks para outros comutadores.

Como nao podia deixar de ser entretanto isto acarreta algumas regras a saber, que deva ser definida uma certa hierarquia dentro da rede. Sendo assim existem 3 modos de operação do VTP:

Client: Um comutador em modo cliente, não pode criar vlans locais ou seja armazena-las na base de dados do comutador, mas pode receber e encaminhar informações de vlans a outros comutadores.

Transparent: Um comutador em modo transparente pode criar vlans na sua base de dados, mas nao pode transmiti-la a outros comutadores, no entanto encaminha vlans recebidas de outros comutadores.

Server: Um comutador em modo servidor cria, modifica, apaga, recebe e encaminha vlans a outros comutadores.

Welcome to the new CCNA: me

Realizei finalmente a prova 640-802. A decisão de realizar esta prova foi crucial. Comecei a estudar em Janeiro, tinha pensado marcar a prova para Março mas decidi realizar apenas em Abril.

Desde a primeira hora decidi marcar a prova 640-802 em Inglês na Torque IT. Acabei a prova muito antes, faltavam ainda uns 26 minutos. Obtive um Score de 936.

Actualização: O que saiu na prova: 2 labs, um de eigrp (tinha que trocar o AS e configurar as redes directamente conectadas) outro de acl (barrar acesso web a todas estações menos uma ao servidor de gestao or something like that. permitir todo outro tipo de tráfego).

Saiu um troubleshotting or something like that de vlans (pegadinhas em vtp e config revision numbers), spanning-tree (identificar root bridge), host to host communications (com base em vlans diferentes da nativa). De resto perguntas teoricas bastante faceis sobre subnetting ipv4, teoria de ipv6, spanning tree, vtp, vlans, frame-relay, ppp, wireless e security (apenas uma).

Tenho de agradecer especialmente a minha amiga Madalena Dias (CCNA) da ACS pelo apoio/experiencia e dicas passadas. Uma força para ti e bons sucessos no estudo do CCNP.

Proximo objectivo: CCNA Security e CCNP.

Redes sociais. Até quando?

Parece uma pergunta algo dificil. De facto é, já que as redes sociais atingiram um grau de maturidade nunca antes visto permitindo a conexão de milhares de usuarios antes geograficamente distantes. No entanto tenho que discordar do excessivo grau de apelação que se faz em torno delas.

É que infelizmente algumas pessoas ainda nao perceberam bem a exposição a que se propoem quando participam de ‘cara’ nestas redes sociais. Se a mim ja me parece exagerado ter mais de 200 amigos me enoja o facto de haver falta de pudor e da conversa fiada que se praticam nestes espaços. É um joguete infantil de exposição de fotos sensuais para ganhar visitas e posts de comentaristas/comentarios hipocritas para receberem algo similar nos seus perfis. Quando o assunto é conversa de verdade aparece a capa da covardia que nao pode passar além dum ‘ya, curti o teu perfil, ta fx’.

Daí  a minha pergunta. Até quando a juventude adolescente (a principal despercebida desse perigo) se aperceberá que está a mercê de grupos organizados de malfeitores, tarados e bandos de pornografia e pedofilia?

EIGRP: Analise de FD, AD nas tabelas de topologia e roteamento.

Continuaremos a analisar o protocolo EIGRP já aqui referido, tal é a sua importancia devido ao facto de ser um protocolo IGP poderoso, a menina dos olhos bonitos da Cisco. Cabe no entanto perceber bem o estabelecimento das tabelas de vizinhança, topologia e rotas.

Atentemos a figura abaixo, uma rede Point-to-Point simples com duas subredes loopback em lugar de LANs:

A sua config (para testar no packet):

Para R3:

Router#sh run
Building configuration...

Current configuration : 739 bytes

interface Loopback0
ip address 172.16.2.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/3/0
ip address 192.168.1.1 255.255.255.252
clock rate 64000
!
interface Serial0/3/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 10
network 172.16.0.0
network 192.168.1.0
no auto-summary
!
ip classless

Para R4:

Router#sh run
Building configuration...

Current configuration : 721 bytes
interface Loopback0
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/3/0
ip address 192.168.1.2 255.255.255.252
!
interface Serial0/3/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 10
network 192.168.1.0
network 172.16.0.0
no auto-summary
!
ip classless

Cabe antes aclarar alguns termos:

FD – Metrica usada por um roteador para alcançar uma rede destino. Feasible Distance é a composição de 2 metricas separadas. A do roteador vizinho para alcançar a rede destino e a sua para alcançar o roteador vizinho.
AD – Também conhecida como RD. Advertised Distance ou Reported Distance é a metrica do roteador vizinho para alcançar a rede destino.
FS – Feasible Sucessor é a rota backup caso a rota cuja metrica seja de FD falhe.
FC – Feasible Condition é a condição alcançada quando o vizinho anuncia uma rota (AD) menor que a FD. Ou seja uma rota apenas é considerada Feasible sucessor se a sua AD for menor que a FD.

Depois de convergida a rede em R3 pretendemos determinar a FD (Feasible Distance) para R4 e em R4 a FD para R3:

Em R3:

Router#sh ip eigrp topology
IP-EIGRP Topology Table for AS 10

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status

P 172.16.2.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 192.168.1.0/30, 1 successors, FD is 2169856
via Connected, Serial0/3/0
P 172.16.1.0/24, 1 successors, FD is 2297856
via 192.168.1.2 (2297856/128256), Serial0/3/0

O seguinte output:

P 172.16.1.0/24, 1 successors, FD is 2297856
via 192.168.1.2 (2297856/128256), Serial0/3/0

P significa interface em estado passivo.
172.16.1.0 é a rede L0 destino que está ligada a R4.
1 successors mostra que existe uma metrica escolhida para alcançar o destino.

FD is 2297856 mostra o valor numerico da metrica escolhida para alcançar a rede destino.
via 192.168.1.2
mostra 192.168.1.2 que é o endereço de proximo salto, endereço este pertencente a interface serial de R4.
2297856 Serial0/3/0 a FD para alcançar 172.16.1.0.
128256 a AD de R4 para alcançar 172.16.1.0 ou seja 128256 é a metrica de R4 para alcançar a rede L0 172.16.1.0.
Serial0/3/0 a interface de saída de R3 directamente conectada ao next-hop 192.168.1.2.

Repare que para a rede 172.16.2.0 directamente conectada a FD é muito curta apenas 128256. Repare para a rede 172.16.1.0 que a FD é 2297856. Isto acontece porque a FD é a soma da metrica de R3 (a FD) para alcançar 172.16.1.0 mais a metrica de R4 (a AD ou RD) para alcançar a rede 172.16.1.0 que é 128256. (exactamente a mesma metrica de R3 para alcançar a sua interface L0 172.16.2.0)

A escolha da metrica FD = 2297856 é verificada porque a tabela de rotas usa a melhor metrica disponivel na tabela de roteamento:

Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 2 subnets
D 172.16.1.0 [90/2297856] via 192.168.1.2, 09:15:35, Serial0/3/0
C       172.16.2.0 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 1 subnets
C       192.168.1.0 is directly connected, Serial0/3/0

Nao vou explicar como se analisa uma tabela de roteamento, poderei faz-lo outro dia, mas repare que D indica que uma rota para 172.16.1.0 foi aprendida por meio do next-hop 192.168.1.2.
172.16.1.0 Rede destino que foi aprendida por R3 por meio de R4.
90 é a distancia administrativa do protocolo EIGRP.
2297856 a metrica de R3 para alcançar a rede 172.16.1.0
via 192.168.1.2 o next-hop directamente conectado a R3.
Serial0/3/0 interface de saída de R3.

A configuração desta rede por outro lado traz problemas, devido ao facto de que se o link que pertence ao segmento 192.168.1.0/30 falhar, nao existe uma Feasible sucessor route ou seja uma rota sucessora um caminho de backup para a rede 172.16.1.0.

De facto a analise das tabelas de vizinhança mostra isto mesmo:

Router#sh ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq
(sec)                  (ms)   Cnt       Num
0   192.168.1.2     Se0/3/0        14   09:32:48  40     1000  0   10

Apenas um neighbor (192.168.1.2) ligado a R3 por meio da interface de saida  Se0/3/0.