Mascaras Curinga (WildCard Masks), rapidamente.

As mascaras curiga ou wildcard masks sao muito utilizadas em configurações de listas de controlo de acesso e também em protocolos de roteamento como OSPF. Serve para aplicações onde as mascaras de subrede nao sao possiveis de se aplicar, por exemplo em casos de nao serem contiguos os endereços de hosts.

Em mascaras curinga o 0 (zero) significa ‘verificar’ e o 255 significa ‘nao verificar’ ou seja, exatamente o contrario das mascaras de sub-rede. Uma forma rápida de determinar a mascara curinga é relaciona-la com a mascara de sub-rede de 32 bists subtraindo-a com a mascara de sub-rede da rede desejada. Depois de realizado este processo, teremos entao a abrangencia necessaria para verificação seja de uma acl ou de um protocolo.

O exemplo acima é de uma rede OSPF com 3 areas. Uma a 0, a outra a 10 e a ultima a 100. Pede-se que se configure a interfaces conforme o exemplo acima e as respectivas areas. Todas as outras interfaces que nao foram atribuidas areas pelo diagrama acima devem ser configuradas com a area 0.

Conforme pode ver é uma rede bem dividida em sub-redes. Vamos primeiro aplicar as configurações a interfaces. A seguinte saida foi gerada por um show running-config num router da serie 3600 no GNS3 for windows.

Router A:

hostname RouterA

interface Loopback0
ip address 192.168.1.1 255.255.255.192
!
interface Loopback1
ip address 10.2.2.1 255.255.255.224
!
interface Serial0/0
ip address 172.20.1.1 255.255.255.252
serial restart-delay 0

Router B:

hostname RouterB

interface Loopback0
ip address 10.1.1.1 255.255.255.240
!
interface Loopback1
ip address 192.168.10.1 255.255.255.248
!
interface Serial0/0
ip address 172.20.1.2 255.255.255.252
serial restart-delay 0

Depois de configuradas as interfaces habilita-se o protocolo OSPF.

Router A:

router ospf 20
log-adjacency-changes
network 10.2.2.0 0.0.0.31 area 0
network 172.20.1.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.63 area 10

Router B:

router ospf 20
log-adjacency-changes
network 10.1.1.0 0.0.0.15 area 100
network 172.20.1.0 0.0.0.3 area 0
network 192.168.10.0 0.0.0.7 area 0

Voltemos ao nosso assunto. Por exemplo no Router A, foi aplicado o seguinte comando:

network 10.2.2.0 0.0.0.31 area 0

Reparem na mascara curinga :

0.0.0.31

Ela foi calculada de forma simples, subtraindo a mascara de subrede todos ‘1’ 255.255.255.255 pela mascara de subrede /27 ou 255.255.255.224, ou seja:

255.255.255.255
-255.255.255.224
_______________
0.0.0.31

Ainda no RouterA, repare na subrede 192.168.1.1/26. Para encontrar a sua mascara curinga subtraia (em decimal):

255.255.255.255
-255.255.255.192
_______________
0.0.0.63

Ou entao de forma mais facil, poderiamos determinar esta mascara curinga fazendo

/32 - /26 = /6. Logo 2^6 = 64-1 = 63

, conforme determinado acima.

Entao nao tem segredo. Se quiser determinar rapidamente uma mascara curinga de uma determinada sub-rede subtraia a mascara de sub-rede todos ‘1’ por ela, conforme os exemplos acima.

7 pensamentos sobre “Mascaras Curinga (WildCard Masks), rapidamente.

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s